> Possible solution:
> It would be really nice if a mask etc. could be applied to an element simply by
> making it a child of that element.
I like the idea.
> This is currently how animations work. An
> <animate> element can either refer to its target by xlink:href="#id" or, if no
> such attribute exists, it will default to targeting its parent element.
Why make it the default as this breaks existing content. Why not have something like a 'target-element' property (for lack of a better name) with two values 'parent' or 'by-reference', the default one being 'by-reference'.
> Using that approach, instead of:
> <filter id="myFilter">
> <path filter="url(#myFilter)"/>
> You could have:
This would give:
> But, of course, that breaks existing content such as:
> <filter id="MyFilter">
> <path filter="url(#MyFilter)"/>
> I think our next best option is to extend the syntax.
> For properties we could have:
> clip-path: <funciri> | none | inherit | child
> If it's 'child', it means "find the first child element that is a <clipPath> and use
Somehow I think it's better if the child references the parent, than the other way round.
> For 'xlink:href' attributes it's a bit more difficult since really all 'xlink:href'
> attributes should take the same values.
Didn't we say that we wanted to introduce alternate attributes to xlink:href (e.g. src for image ...) to avoid namespace issues? If this was the case, we would have more freedom to define it as needed.
The information contained in this email message and any attachments may be confidential and may also be the subject to legal professional privilege. If you are not the intended recipient, any use, interference with, disclosure or copying of this material is unauthorised and prohibited. If you have received this email in error, please immediately advise the sender by return email and delete the information from your system.