>>> Main reason to change the names of the functions are the patches in the patch
>>> tracker and and in other places at the web which would all fail to work if
>>> using still the old interface (anybody really cares about the compiler
>>> warnings?). The same problem we had already when paged_load/write changed
>>> their interfaces. Using new names, people get at least a compiler error and
>>> must fix this to be able to use paged functions again.
>> Why not implement eeprom_write/read_page() and flash_write/read_page() functions?
>> Some programmers already split these functions up and when AVRDUDE calls the appropriate functions directly, a lot of code duplication can be removed.
> And what about other memory regions as application, apptable, boot used
> in the xmega family? I think we should like write/read_byte use a single
> interface for all kind of memory.
I wasn't aware, that there are so many different memory regions.
In that case, a single interface is probably a good idea, although a table based approach would incur less code duplication.
I don't think a new interface should be pushed, but if someone has some time on their hands, I think it would be a good idea to re-structure the programming code.