UI looks fine
The only thing that stood out was:
_copyToAllTabsAction = copyInputToAllTabsAction;
I see where we use it later; perhaps use the _copy instead of the copy? and/or add comment.
On March 9th, 2012, 5:02 a.m., Jekyll Wu wrote:
Review request for Konsole.
By Jekyll Wu.
Updated March 9, 2012, 5:02 a.m.
The existing UI is misleading: the three check boxes imply that you can enable any of them independently, but actually you can only enable one of them at any time. So the three choices should be shown using combo boxes instead of check boxes.
The code is basically stolen from dolphin. Again, I'm always not that confident with UI changes, so please check the code for any stupid or unnecessary code.